首页 文章详情

hdu 2095 find your present (2)

ACM比赛整理 | 296 2021-08-28 00:40 0 0 0
UniSMS (合一短信)

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37958    Accepted Submission(s): 14807


Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

 


Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

 


Output

For each case, output an integer in a line, which is the card number of your present.

 


Sample Input

5
1 1 3 2 2
3
1 2 1
0

 


Sample Output

3
2


Hint


use scanf to avoid Time Limit Exceeded



解题思路:

1 1 2 3 3
输出出现奇数个的数(有且只有一个)
因为2出现俩次
所以用疑惑
1^0=1
1^1=0
一个循环后 s=0的值不变


代码:

#include<stdio.h>
int main()
{
int n,s,a;
while(scanf("%d",&n),n)
{
while(n--)
{
scanf("%d",&a);
s ^= a;
}
printf("%d\n",s);
}
return 0;
}



good-icon 0
favorite-icon 0
收藏
回复数量: 0
    暂无评论~~
    Ctrl+Enter